52 lines
1.5 KiB
Nix
52 lines
1.5 KiB
Nix
{
|
|
description = "A flake for building your Python module";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
|
|
};
|
|
|
|
outputs = { self, nixpkgs }:
|
|
let
|
|
pkgs = import nixpkgs { system = "x86_64-linux"; };
|
|
python-nostr = pkgs.python3Packages.buildPythonPackage rec {
|
|
pname = "nostr";
|
|
version = "0.0.2-beta";
|
|
|
|
doCheck = false;
|
|
src = pkgs.fetchFromGitHub {
|
|
owner = "jeffthibault";
|
|
repo = "python-nostr";
|
|
rev = "main";
|
|
sha256 = "sha256-ozpE9ObDie9vmse+Xub4MHuMHmFO567Cc/OIa/JHZsA=";
|
|
};
|
|
propagatedBuildInputs = with pkgs; [
|
|
python3Packages.secp256k1
|
|
python3Packages.cryptography
|
|
];
|
|
meta = with pkgs.lib; {
|
|
description = "Nostr module for Python";
|
|
license = licenses.mit;
|
|
maintainers = with maintainers; [ jeffthibault ];
|
|
};
|
|
};
|
|
nostr-vanity = pkgs.python3Packages.buildPythonPackage rec {
|
|
pname = "nostr-vanity";
|
|
version = "0.0.2";
|
|
|
|
doCheck = false;
|
|
src = ./.;
|
|
propagatedBuildInputs = [ python-nostr ];
|
|
meta = with pkgs.lib; {
|
|
description = "Nostr vanity generator for Python";
|
|
license = licenses.mit;
|
|
maintainers = [ "abstractequilibrium" ];
|
|
};
|
|
};
|
|
in
|
|
{
|
|
#defaultPackage.x86_64-linux = python-nostr;
|
|
defaultPackage.x86_64-linux = nostr-vanity;
|
|
packages.x86_64-linux = python-nostr;
|
|
};
|
|
}
|